java.lang.IllegalArgumentException: Argument for @NotNull parameter 'file' of com/intellij/openapi/module/ModuleUtilCore.findModuleForFile must not be null

Published on with 97 views

事件起因

用idea社区版的smart Tomcat 打开一个eclipse的javaweb项目

问题根本原因

JAVA SDK版本没选对

解决办法

用idea从新导入eclipse项目

  1. File --> open
  2. 选择.project 文件打开
  3. 根据提示修改 SDK 信息


Responses